Evolution
Тема интерфейса

Серверы в целевой группе недоступны после настройки сервиса проверки доступности

Описание проблемы

Все серверы в целевой группе стали недоступны после настройки сервиса проверки.

Решение

Возможные причины:

  • В настройках сервиса проверки указан порт, на котором ваше приложение не слушает запросы.

    Например, проверка идет на 80-й порт, а приложение слушает 8080.

  • В группах безопасности на целевых серверах или других средствах фильтрации заблокирован порт/протокол, используемый для проверки.

  • Приложение не отвечает на указанный путь при проверках по HTTP.

  • Ваше приложение на запрос от сервиса проверки шлет «OK» c кодом ответа, отличным от 200.

  • Заданы слишком «строгие» параметры сервиса проверки: маленькие значения таймаута, частые проверки, маленький порог ошибок.

    Это приводит к быстрому исключению серверов даже при незначительных задержках в пиках нагрузки.

Чтобы устранить проблему:

  1. Проверьте и скорректируйте параметры сервиса проверки: порт, путь, ожидаемый ответ.

  2. Убедитесь, что группы безопасности пропускают трафик между ресурсными единицами балансировщика и проверяемыми серверами.

  3. Если причина неясна — временно отключите сервис проверки и проверьте доступность приложения.

  4. Если проблема не исчезнет, обратитесь в техническую поддержку с указанием:

    • ID проекта и ID балансировщика;

    • ID целевой группы, если проблема связана с ней.